cmdref.net - Cheat Sheet and Example

cmdref.net is command references/cheat sheets/examples for system engineers.

User Tools

Site Tools


Sidebar








Etc


Reference














.

hardware:cisco:etherchannel.html



Cisco IOS, NX-OS

Cisco Etherchannel Configuration Examples

EtherChannel allows multiple physical Fast Ethernet or Gigabit Ethernet links to be combined into one logical channel.



Show

Operation Command
switch#show etherchannel summary
switch#show etherchannel protocol
switch#show port group
switch#show port channel
switch#show port channel info
switch#show etherchannel summary
switch# show interfaces port-channel NO


Check Commands

Switch#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel   Protocol      Ports
------+-------------+-----------+--------------------------
1      Po1(SU)        LACP       Fa0/1(P)  Fa0/2(P)


Configuration

static : mode on

(1)Physical Interface
Switch1# conf t
Switch1(config)# interface range FastEthernet 0/11
Switch1(config-if)# channel-group 1 mode on           <-  Create "Port-channel1" interface
Switch1(config-if)# description test02-l2_12

Switch1(config-if)# interface range FastEthernet 0/12
Switch1(config-if)# channel-group 1 mode on            <-  Create "Port-channel1" interface
Switch1(config-if)# description test02-l2_12


(2)Logical Interface
Switch1(config)# interface port-channel 1
Switch1(config-if)# description test02-l2_11-12
Switch1(config-if)# switchport trunk encapsulation dot1q
Switch1(config-if)# switchport mode trunk
Switch1(config-if)# switchport trunk native vlan 555
Switch1(config-if)# switchport trunk allowed vlan 50,100,110,555

LACP : mode active

Switch# configure terminal
Switch(config) # interface range gigabitethernet 1/0/1 , gigabitethernet2/0/1
Switch(config-if-range) # switchport trunk encapsulation dot1q
Switch(config-if-range) # switchport mode trunk
Switch(config-if-range) # channel-group 1 mode active


Adding VLAN & Deleting VLAN

Add VLAN for the Port-channel

When adding a VLAN, be sure to do it only for the port channel.
If it is set to port channel, it will also be reflected on member port.

Switch1(config)# interface port-channel 1
Switch1(config-if)# switchport trunk allowed vlan add 93

Delete VLAN from Port-channel

Switch1(config)# interface port-channel 1
Switch1(config-if)# switchport trunk allowed vlan remove 93


Delete port from Channel Group




hardware/cisco/etherchannel.html.txt · Last modified: 2018/09/16 by admin