cmdref.net - Cheat Sheet and Example

cmdref.net is command references/cheat sheets/examples for system engineers.

User Tools

Site Tools


Sidebar








Cloud



Etc


Reference














.

hardware:alista:index.html



Arista EOS CLI Commands

Corporate Sites

Commands

switch> enable
switch# configure
switch(config)#
veos> enable
veos# bash
show version Serial Number
show inventory

User

username admin secret XXXXXX

Interfaces

https://www.arista.com/en/um-eos/eos-section-11-4-interfaces

The SFP-1G-T transceivers advertise one speed at a time only. Hence, the desired speed and negotiation must be configured explicitly using the following commands:
speed auto: auto-negotiated 1Gbps (this is because no speed is specified and we are defaulting to advertise 1G).
speed auto 1G full/ speed 1G: auto-negotiated 1Gbps (note that per BASE-T standard, 1G must be negotiated)
speed auto 100full: auto-negotiated 100Mbps
speed 100full: non-negotiated/true-forced 100Mbps

Port Channel

switch(config)#interface ethernet 1-2
switch(config-if-Et1-2)#channel-group 10 mode active
switch(config-if-Et1-2)#show active

VLAN

switch(config)#vlan 45
switch(config-vlan-45)#
Access Ports
switch(config)#interface ethernet 5
switch(config-if-Et5)#switchport access vlan 15
switch(config-if-Et5)#
Trunk Ports
switch(config)#interface ethernet 12-16
switch(config-if-Et12-16)#switchport trunk allowed vlan 15,20-22,40,75
switch(config-if-Et12-16)#
switch(config)#interface ethernet 14
switch(config-if-Et14)#switchport trunk allowed vlan add 100-120
switch(config-if-Et14)#


NAT

7150S#show ip nat translation static
Source IP       Destination IP       Translated IP         TGT Type Intf
----------------------------------------------------------------------------
10.0.0.15:0       -                     20.0.0.15:0           SRC STAT Et6
Source NAT

These commands configure VLAN 201 to translate source address 10.24.1.10 to 168.32.14.15.

switch(config)#interface vlan 201
switch(config-if-Vl201)#ip nat source static 10.24.1.10 168.32.14.15
switch(config-if-Vl201)#


VRF

sh vrf
sh ip route vrf vrf1
ping vrf vrf2 192.168.204.1
vrf definition vrf1
   rd 65000:1

vrf definition vrf2
   rd 65000:2

interface Vlan301
   vrf forwarding vrf1
   ip address 30.0.1.254/24

interface Vlan401
   vrf forwarding vrf2
   ip address 40.0.1.254/24


ip route vrf vrf1 40.0.1.0/24 30.0.2.1
ip route vrf vrf2 30.0.1.0/24 40.0.12.1


ip routing
ip routing vrf vrf1
ip routing vrf vrf2

LLDP

# show lldb
# no lldp run   <- Disable LLDP


Spanning-tree

# no spanning-tree 1-4097


BGP


Multicast

Check
show ip pim interface
show ip pim neighbor
show ip pim rp
show ip pim rp detail
show ip mroute
Enabling IPv4 Multicast Routing
ip routing
ip multicast-routing

interface Ethernet1
   ip pim sparse-mode

ip pim rp-address 172.16.1.254

ip route 172.16.2.0/24 172.16.1.254
switch(config)#router multicast
switch(config-router-multicast)#ipv4
switch(config-router-multicast-ipv4)#routing



Enables PIM and IGMP on VLAN interface.

Allie(config-if-vl20)#interface vlan 21
Allie(config-if-vl21)#pim ipv4 sparse-mode
Allie(config-if-vl21)#interface vlan 24
Allie(config-if-vl24)#pim ipv4 sparse-mode
Allie(config-if-vl24)#interface vlan 10
Allie(config-if-vl10)#pim ipv4 sparse-mode
Allie(config)#router multicast
Allie(config-router-multicast)#ipv4
Allie(config-router-multicast-ipv4)#routing
Allie(config-router-multicast-ipv4)#activity polling-interval 5
Allie(config-router-multicast-ipv4)#router pim sparse-mode
Allie(config-router-pim-sparse)#ipv4
Allie(config-router-pim-sparse-ipv4)#rp address 10.25.10.15


Clock(PTP)

switch(config)#clock timezone US/Central
switch(config)#show clock
Mon Jan 14 18:42:49 2013
timezone is US/Central


TimeStamp

References




Arista EOS CLI Commands





Hardware




hardware/alista/index.html.txt · Last modified: 2021/05/24 by admin

Page Tools